ReGet Help

Download Intelligente con ReGet 1.7

Come usare ReGet?
La cosa principale su ReGet è che puoi formare liste di scaricamenti. Puoi aggiungere un nuovo scaricamento alla lista in uno dei seguenti modi:
  • Cliccando "Download using ReGet" nel menu contestuale di Internet Explorer (appare premendo il tasto destro del mouse sul link).
  • Trascinando il link dal tuo browser preferito e depositandolo nella finestra di ReGet.
  • Abilitando ReGet a monitorare la Cartella Appunti, quindi semplicemente premendo il tasto destro del mouse sul link al file voluto nel tuo browser e scegliendo "Copia collegamento".
  • Oppure, puoi utilizzare "Copia collegamento" nel tuo browser e aggiungerlo manualmente alla lista premendo "Ctrl+V" o selezionando "Incolla" dal menu "Modifica" di ReGet.
  • Ancora, puoi utilizzare "Copia collegamento" nel tuo browser, quindi premere il tasto destro del mouse sull'icona di ReGet nella barra di sistema e selezionare "Incolla" dal menu.
  • Infine, puoi digitare manualmente l'URL voluto dopo aver selezionato, nel menu "Scaricamenti", il submenu "Nuovo scaricamento...".
Si può usare ReGet in Modalità Semplice o in Modalità Avanzata. La Modalità Semplice è pensata per i principianti, ha solo le funzioni minime necessarie. Nella Modalità Avanzata si possono dettagliare le impostazioni. (Tutte le descrizioni delle caratteristiche avanzate sono scritte in rosso.)

ReGet può essere avviato con l'interfaccia in inglese. Per cambiare l'interfaccia in una delle altre lingue, selezionare nel menu del programma: Visualizza -> Language, quindi selezionare la lingua desiderata.

Home Page di ReGet: www.reget.com

Se vuoi ricevere automaticamente notifiche sulle nuove versioni di ReGet via e-mail, iscriviti alla "Newsletter di ReGet" sul nostro server web.

Ultima modifica, 26 Gennaio 2000.


Toolbar

Barra degli strumenti

Barra degli strumenti in modalità Semplice
Barra degli strumenti in modalità Avanzata

Apre un file contenente una lista
Aggiunge una lista di scaricamenti alla lista corrente
Salva la lista di scaricamenti
 Incolla un URL dagli Appunti
Aggiunge un nuovo scaricamento
Cancella tutti gli scaricamenti selezionati
Cancella tutti gli scaricamenti completati
 Sospende gli scaricamenti selezionati
Avvia lo scaricamento dei file selezionati
Mostra la finestra delle Proprietà
Visualizza il log
Sposta lo scaricamento in basso
Sposta lo scaricamento in alto
Modalità sospeso
Modalità cooperativo
Modalità ad alta priorità
Nasconde/Visualizza la griglia
Nasconde/Visualizza l'indicatore di progressione
 Connette/Disconnette
Va alla Home Page di ReGet
Va alla pagina download di ReGet per scaricarne la versione più recente. Se sul server non è presente una versione più recente di ReGet, questo tasto non è visibile.


Default download properties

Proprietà di scaricamento predefinite

Le impostazioni di tutte le sezioni in questa finestra saranno applicate ad OGNI nuovo download aggiunto alla lista, a meno che non venga selezionato "Usa le proprie impostazioni avanzate" e cambiate manualmente le diverse proprietà di scaricamento.
URL
"Salva i file scaricati nella cartella" . Specifica la cartella nella quale salvare il file scaricato. Se la cartella non esiste, verrà creata.
"Sfoglia..." . Questo pulsante fa apparire una finestra dove è possibile selezionare la cartella nella quale salvare i file scaricati. La scelta effettuata viene mostrata nel campo sovrastante.
"Crea" - È possibile creare la cartella nella quale salvare i file scaricati.
"Effettua il login sul server" . Se il server (sia FTP che HTTP) dal quale stai scaricando i file richiede l'autenticazione, seleziona questa casella, potrai così specificare username/password nei campi sottostanti. NOTA: Quando questa casella è selezionata e username/password sono inseriti, ReGet utilizzerà quegli username/password per OGNI download aggiunto alla lista, fino a quando non si seleziona "Usa le proprie impostazioni avanzate" e si cambia manualmente ciascuna proprietà di scaricamento.
"User name" . Se il server (sia FTP che HTTP) dal quale stai scaricando i file richiede l'autenticazione, puoi specificare qui l'username per questo server.
"Password" . Se il server (sia FTP che HTTP) dal quale stai scaricando i file richiede l'autenticazione, puoi specificare qui la password per questo server.
"Stringa di Referrer". Qui si può specificare l'URL della pagina dove si trova il link al file.
"Usa le proprie impostazioni avanzate" . Quando questa casella è selezionata, si accede alle altre sezioni (Download, Proxy, FTP, HTTP) di questa finestra (in altre parole, si va in Modalità Avanzata).
Scaricamento
"Inizia automaticamente lo scaricamento dopo un'aggiunta". Se questa casella è selezionata, il nuovo scaricamento sarà automaticamente avviato dopo essere stato aggiunto alla lista.
"Inizia gli scaricamenti in pausa dopo il caricamento della coda" - Se questa casella è selezionata, tutti gli scaricamenti saranno automaticamente avviati all'avvio di ReGet.
"Cancella dalla coda al completamento" . Quando questa casella è selezionata, lo scaricamento viene eliminato dalla lista una volta terminato con successo.
"Ricomincia automaticamente dopo ... disconnessioni" . Se questa casella è selezionata, ReGet ritenterà lo scaricamento per il numero di volte specificato. Il valore "0" indica tentativi infiniti.
"Pausa ... secondi" - Attende per un numero specificato di secondi prima del tentativo successivo.
"Restart in case of low speed". Riavvia il download quando la velocità è inferiore a quella specificata.
File
"Non ricominciare da capo se lo scaricamento non può essere ripreso" - . Se questa casella è selezionata, e il server dal quale si sta scaricando non supporta la ripresa dei download interrotti, e il download si interrompe, ReGet non cancellerà la porzione di file scaricata e non ricomincerà lo scaricamento. Sicchè, se un file è situato su un numero diverso di server, e si sono già scaricati 10Mb da un server che non supporta la ripresa degli scaricamenti interrotti, è possibile andare su un server più lento (ma che supporti la ripresa) e portare a termine lo scaricamento dalla posizione corrente.
"Ottieni data e ora del file dal server". Se questa casella è selezionata, il file scaricato avrà la stessa data che ha sul server. Dai server FTP, ReGet richiede la data con il comando "LIST -L", dai server HTTP ReGet prende la data dal campo "Ultima Modifica".
"Usa l'attributo di file nascosto per file ancora incompleti" . Quando questa casella è selezionata, i file non completamente trasferiti sono contrassegnati come nascosti e solo a scaricamento avvenuto con successo saranno contraddistinti come non nascosti (e saranno visibili nella cartella).
"Aggiorna il file descript.ion" - Se la casella è selezionata, una descrizione (contenuto della colonna "Descrizione" e URL) di ogni file scaricato viene aggiunta al file descript.ion nella cartella dove si colloca il file.
Proxy
"Usa il Proxy HTTP" . Usa questo proxy per i server HTTP. Il formato è il seguente: proxy.dominio.com:8080.
"Usa il Proxy FTP" . Usa questo proxy per i server FTP. Il formato è il seguente: proxy.dominio.com:8080.
"Username" . Se il tuo proxy richiede l'autenticazione, inserisci qui lo username. Per il Microsoft Proxy Server, il formato è il seguente: Dominio\Username.
"Password" . Se il tuo proxy richiede l'autenticazione, inserisci qui la password.
"Tipo di Proxy FTP" . Qui si può specificare il tipo di proxy FTP.
"HTTP" - Seleziona questa casella se utilizzi un proxy HTTP.
"user@site (WinGate)" - Seleziona questa casella se utilizzi MS Proxy.
"Rollback ... byte" . Quando si utilizza un server proxy e la connessione si interrompe, ReGet tenterà di correggere i ... bytes. Per favore, leggi ulteriori informazioni al riguardo nelle F.A.Q. di ReGet alla voce "Smart Rollback".
"Smart rollback" . Quando questa casella è selezionata, ReGet utilizza la modalità "Smart Rollback". Ulteriori informazioni sono presenti nelle F.A.Q. di ReGet alla voce "Smart Rollback" .
"Forza il proxy a ricaricare il file" . Se si usa un proxy HTTP, selezionando questa casella si forzerà il proprio server proxy a ricaricare il file che si sta scaricando dalla sua posizione originale piuttosto che dalla copia nella cache.
"Lista di messaggi di errore del Proxy" - Qui si possono specificare i possibili inizi dei messaggi d'errore, così che ReGet possa tagliare la parte di file che comincia con questi codici.
FTP
"Timeout ... secondi" . Se ReGet non riceve dati dal server entro l'intervallo di tempo specificato, lo scaricamento si interrompe..
"modo ASCII" . Scarica questo file come documento di testo. Questa opzione avvia la conversione da [LF] a [CR][LF].
"modo PASV" . Scarica questo file utilizzando la modalità PASV. La modalità PASV si usa quando si scaricano file usando un server proxy. Ulteriori informazioni sono presenti nelle F.A.Q. di ReGet alla voce "Modalità PASV".
"Non inviare QUIT (per collegamenti molto lenti)" . Quando questa opzione è selezionata, ReGet non invierà il comando QUIT.
"Avanzate ('?' o '*' nell'URL)" . Queste impostazioni influenzano gli URL con wildcards (maschere).
"Includi le sottodirectory" . Se questa casella è selezionata, ReGet salverà tutti i file nelle corrispondenti sottodirectory.
"Crea la struttura delle directory" . Quando questa casella è selezionata, ReGet duplica nella cartella di scaricamento la struttura della cartella del server FTP.
"Il percorso dell'URL è relativo alla home directory" - Se questa casella è selezionata, il percorso dell'URL è relativo alla cartella alla quale si viene indirizzati una volta collegati al server.
HTTP
"Timeout ... secondi" . Se ReGet non riceve dati dal server entro l'intervallo di tempo specificato, lo scaricamento si interrompe.
"Stringa di User-Agent" . Nel corso della comunicazione con il server web, ReGet gli sottopone le informazioni sullo user-agent. In parole povere, lo user-agent è il programma che si utilizza per scaricare i file. Per impostazioni predefinite, ReGet invia la propria versione come user-agent. Tuttavia, alcuni server consentono lo scaricamento dei file solo se effettuato dai normali browser, non da speciali Gestori di Download (come ReGet). Se si incontra questo problema, è possibile cambiare questo campo, in modo da aggirare il server al quale sembrerà che si stia usando un normale browser (si può selezionare quello che si preferisce).
"Forza l'uso dei cookies" - Se la casella è selezionata, ReGet proverà sempre ad utilizzare i cookies.


Main Menu

Menu Principale
File
"Esci" . Abbandona il programma
"Nuovo" (Ctrl+N) . Crea una nuova lista di scaricamenti, file (.WRG).
"Apri" (Ctrl+O) . Apre una lista esistente di scaricamenti, file (.WRG).
"Importa lista..." (Ctrl+L) . Importa un elenco di indirizzi da un file di testo. Ogni stringa del file deve essere un URL valido.
"Incolla..." (Ctrl+M) . Incolla la lista corrente con un'altra lista, file (.WRG).
"Salva" (Ctrl+S) . Salva la lista degli scaricamenti, file (.WRG).
"Save con nome..." . Salva la lista degli scaricamenti, file (.WRG), con un nome diverso.
Modifica

"Incolla URL"(Ctrl+V). Incolla un URL dalla Cartella Appunti alla lista corrente. Tutte le impostazioni per un nuovo download sono ricavate dalle impostazioni predefinite.
"Seleziona tutto"(Ctrl+A). Seleziona tutti i download nella lista corrente.
"Copia" -Copia nella Cartella Appunti tutti gli scaricamenti selezionati
"Cancella tutto" - Cancella tutti gli scaricamenti
Visualizza
"Barra degli strumenti" . Visualizza/Nasconde la barra degli strumenti.
"Stringa di stato" . Visualizza/Nasconde la barra di stato (sul fondo delle finestre di ReGet).
"Barra del diagramma". Visualizza/Nasconde la barra del diagramma
"Minimizza all'avvio" . Fa in modo che all'avvio ReGet si minimizzi automaticamente sulla barra di sistema.
"Language" . Seleziona la lingua dell'interfaccia utente.
Scaricamenti
"Nuovo scaricamento..."(Alt+N) – Aggiunge un nuovo scaricamento alla coda corrente. Questo strumento del menu lancia una finestra in cui si possono inserire i dettagli dei nuovi scaricamenti.
"Avvia"(Alt+S) – Avvia lo scaricamento corrente.
"Pausa"(Alt+P) – Sospede lo scaricamento corrente.
"Cancella"(Alt+Del) – Cancella il download corrente da una lista. Ciò NON cancella il file scaricato dal tuo hard disk.
"Cancella completi" – Cancella dalla lista tutti i download completamente riusciti. Ciò NON cancella il file scaricato dal tuo hard disk.
 "Proprietà..."(Alt+Enter) – Per cambiare le impostazione degli scaricamenti.
"Visualizza log..." (Alt+L) – Visualizza/Nasconde la finestra del log per un download. Puoi visualizzare i log di scaricamenti differenti in una volta sola.
"Sposta in alto" (Alt+Up) – Sposta in alto lo scaricamento. (quanto più in alto è il download nella lista, tanto più in fretta verrà cominciato).
"Sposta in basso"(Alt+Down) – Sposta in basso lo scaricamento. (quanto più in basso è il download nella lista, tanto più in ritardo verrà cominciato).
"Apri il file scaricato"(Enter) – Apre il file scaricato (lo esegue, o esegue il programma associato alla sua estensione).
"Apri cartella destinazione"(Ctrl+Enter) – Apre la cartella nella quale è salvato il file.
Opzioni
"Simple mode" - Passa alla Modalità Semplice
"Advanced mode" - Passa alla Modalità Avanzata
"Proprietà di scaricamento predefinite..." (Alt+Ctrl+O) - Proprietà usate da ciascun download se la casella "Usa le proprie impostazioni avanzate" non è selezionata
"Opzioni..." (Alt+O) - Opzioni usate da tutto il programma
"Salva come predefinite" - Salva le impostazioni correnti come predefinite
"Priorità di traffico" - priorità di traffico di ciascun download
"Sospeso" - traffico minimo
"Cooperativo" - traffico moderato
"Alta priorità" - traffico massimo
Aiuto

"Informazioni su..." . Informazioni sulla versione del programma.
"Pagina WWW di ReGet" . Avvia il tuo browser predefinito e apre la Home Page di ReGet.
"Documentazione in linea"(F1) . Apre la documentazione in linea.
"Registra ReGet" (F4) . Fa apparire la finestra di registrazione.
"Enter registration code"(Ctrl-F4) - Fa apparire la finestra nella quale immettere il codice di registrazione.
"Invia E-mail" . Lancia in esecuzione il tuo programma di posta per farti inviare una e-mail all'autore.


Program options

Opzioni

Generali
"Se non ci sono scaricamenti attivi esci dopo ... secondi"– Se questa casella è selezionata, quando non ci sono scaricamenti attivi, o gli scaricamenti sono in pausa o sospesi a causa di un errore, ReGet si chiuderà automaticamente dopo il numero di secondi specificato.
"Disabilita tutti i suoni" – Per disattivare tutti i suoni che ReGet può produrre, selezionare questa casella.
"Imposta i suoni" - Fa apparire la finestra di selezione dei suoni per i diversi avvenimenti
"Esci se è impossibile scaricare per ... secondi"– Quando impostato, ReGet si chiuderà automaticamente dopo il numero di secondi specificato se non riesce a scaricare nulla in tutti i file della lista.
"Chiudi sessione all'uscita" – Quando impostato, ReGet si disconnetterà da internet e arresterà il sistema all'uscita (utile se si lascia il pc acceso solo per scaricare i file).
"Forza la chiusura della sessione" – Quando impostato, ReGet forzerà l'arresto del sistema anche se alcuni task non rispondono a Windows. Suggeriamo di chiudere di persona tutti i programmi che potrebbero chiedere il salvataggio dei propri documenti (Microsoft Word, etc.) prima di arrestare il sistema attivando questa funzione.
"Salva automaticamente la coda ogni ... minuti"– È possibile attivare il salvataggio automatico dello scaricamento corrente dopo uno specificato numero di secondi e alla chiusura di ReGet. Questa caratteristica non funziona se la coda non è stata salvata.
"Il tasto di chiusura minimizza ReGet"– Seleziona questa casella per usare il tasto di chiusura per minimizzare il programma.
"Permetti una sola istanza di ReGet" – Quando si seleziona questa casella, ReGet non avvierà una seconda istanza.
"Salva le impostazioni nel file di coda" – Permette di salvare in un file di coda le impostazioni di scaricamento predefinite del programma.
Monitor
"Monitorizza" - Se la casella è selezionata, qualsiasi URL copiato negli Appunti viene aggiunto automaticamente alla lista
"Ignora le estensioni" - Qui è possibile specificare le estensioni dei file che non saranno automaticamente aggiunti dagli Appunti alla lista
"Netscape Navigator"- Se la casella è selezionata, ciascun collegamento cliccato in Netscape Navigator sarà automaticamente aggiunto alla lista
"Internet Explorer"- Se la casella è selezionata, ciascun collegamento cliccato in Internet Explorer sarà automaticamente aggiunto alla lista
"Ignora le estensioni"- Qui è possibile specificare le estensioni dei file che saranno ignorati quando si aggiunge un URL tramite click
"Conferma" - Se la casella è selezionata, si possono modificare le proprietà di scaricamento prima che un file venga aggiunto automaticamente dagli Appunti alla lista
"Apri gli URL annullati nel browser"- Se si disabilita l'aggiunta degli URL nella lista degli scaricamenti, questi vengono aperti nel browser
"Necessaria conferma" - Se la casella è selezionata, è necessario confermare gli scaricamenti aggiunti tramite click dal browser
"Usa il tasto ALT"- Se la casella è selezionata, è necessario tenere premuto il tasto ALT mentre si clicca per aggiungere un URL alla lista
"Conferma quando si aggiunge con Drag&Drop"- Se la casella è selezionata, ReGet chiederà di confermare gli scaricamenti aggiunti tramite Drag&Drop
"Conferma quando si aggiunge dal menu di contesto di MSIE"- Se la casella è selezionata, ReGet chiederà di confermare gli scaricamenti aggiunti dal menu contestuale di MSIE
Limiti
"Numero massimo di scaricamenti" – Qui si dovrebbe specificare il numero di scaricamenti simultanei consentiti. Se si aggiunge un nuovo scaricamento mentre il numero consentito è già stato raggiunto, il nuovo scaricamento sarà messo in attesa fino all'arrivo del suo turno (quando termina uno scaricamento già attivo). Quando termina un download attivo e nella lista vi sono scaricamenti in attesa, verrà avviato quello più in alto.
"Modalità ad alta priorità" - ReGet funzionerà con il traffico massimo
"Modalità cooperativa ... b/s" – Nella modalità Cooperativa, ReGet produrrà una minore quantità di traffico. Ciò fornirà più traffico per navigare/postare/chattare.
"Modalità sospesa ... b/s"– Nella modalità Sospesa, ReGet produrrà la minima quantità di traffico. Ciò fornirà ancora più traffico per navigare/postare/chattare.
Dial Up
"Non effettuare connessione dial-up"- Quando si avvia uno scaricamento ReGet non controlla che vi sia o meno una connessione.
"Effettua questa connessione" - Quando si avvia uno scaricamento ReGet controlla che vi sia o meno una connessione e si connette nel caso essa manchi.
"Aspetta una connessione" - Quando si avvia uno scaricamento ReGet controlla che vi sia o meno una connessione e ne attende una qualsiasi nel caso si sia al momento disconnessi.
"Disconnetti quando il download è terminato" - Si disconnette al termine di tutti gli scaricamenti
"Numero di tentativi di connessione" - specifica il numero di tentativi di connessione
"Secondi tra i tentativi" - specifica il numero di secondi tra i tentativi
"Connetti alle" - specifica l'orario di connessione
"Disconnetti alle" - specifica l'orario di disconnessione
Log
"Salva il log sul file" - da qui è possibile selezionare il file sul quale salvare il log del programma
"Numero massimo di righe"– La quantità di righe del file di log. Se il file di log supera la lunghezza, vengono cancellate le righe meno recenti.
"Eventi dell'applicazione" - Se la casella è selezionata, tutti gli eventi dell'applicazione vengono indicati nel log del programma
"Log dettagliato delle connessioni dial-up" - Se la casella è selezionata, i dettagli vengono indicati nel log del programma
"Messaggi di debug" - Se la casella è selezionata, messaggi addizionali di debug sono indicati nel log del programma. Non è necessario lasciare selezionata questa casella in modo permanente, ma il servizio di supporto tecnico potrebbe chiedere di selezionarla per risolvere un problema.
"Log degli eventi ActiveX" - Se la casella è selezionata, alcuni messaggi da ActiveX sono indicati nel log dell'applicazione. Non è necessario che questa casella resti selezionata in maniera permanente.
"Errori di scaricamento" - Se la casella è selezionata, gli errori di scaricamento sono indicati nel log del programma.
Conferma
"Disconnessione"- chiede conferma all'utente prima di disconnettersi
"Uscita" - chiede conferma all'utente prima dell'uscita
"Cancellazione di scaricamenti completati" - chiede conferma all'utente prima di cancellare gli scaricamenti completati con successo
"Cancellazione di scaricamenti selezionati" - chiede conferma all'utente prima di cancellare gli scaricamenti selezionati
"Timeout ... secondi" - La finestra di conferma è chiusa automaticamente dopo il numero di secondi specificato come se si fosse premuto il tasto OK.
Colonne
Personalizzazione delle colonne della lista degli scaricamenti . Qui è possibile personalizzare la larghezza e la visibilità delle diverse colonne della lista degli scaricamenti. La larghezza delle colonne è in pixel. La larghezza delle colonne può anche essere cambiata trascinandone i bordi delle varie intestazioni.


Status

Strumenti di Stato

Barra di stato

. Il progresso dello scaricamento per i file selezionati.
. La velocità media/istantanea dello scaricamento.
. L'ammontare complessivo dei byte scaricati.
. L'ingegnoso grafico della velocità di scaricamento.
Icone di stato
Finestra principale (Stato dello scaricamento)
Su questo sito è possibile la ripresa dello scaricamento. Questo sito è "ReGet"-enhanced.
Su questo sito non è possibile la ripresa dello scaricamento. Raramente, al primo tentativo "ReGet" può fallire nel riconoscimento e mostrare questa icona per un sito "ReGet"-enhanced.
Inizio delle comunicazioni con il server. ReGet sta ricevendo informazioni sul file da scaricare.
Scaricamento del file dall'inizio.
ReGet-ting file (riprendendo il file). Ripresa dello scaricamento da dove si è interrotto l'ultima volta.
Ritardo prima del successivo tentativo di scaricamento.
C'è stato un errore critico. "ReGet" non tenterà di scaricare questo file in seguito al verificarsi di un errore critico.
"ReGet" sta cercando di mettere in pausa lo scaricamento. Se esso non può essere messo correttamente in pausa entro 30 secondi, "ReGet" interromperà la connessione con il server.
Lo scaricamento è in pausa.
Lo scaricamento è terminato con successo.
Lo scaricamento è posto in una coda ed è in attesa del suo turno per essere effettuato.
Finestra del Log (Stato del Log)
Stringa di informazioni.
Informazioni ricevute.
Informazioni inviate.
Cambio dello stato dello scaricamento.
Si è verificato un errore.
Connessione.
Informazioni di debug.
Informazioni sul sistema dei banner


Macros

Macro

È possibile usare queste stringhe nelle proprietà di scaricamento URL, Salva i file scaricati nella cartella, e Salva con nome. Ad esempio puoi impostare le proprietà di Salva i file scaricati nella cartella usando
C:\!in\[host]\[path] per sistemare i download nelle cartelle.

[Host]
nome dell'host dall'URL (per esempio www.microsoft.com)
[Host`]
nome dell'host in cui tutti i "." sono sostituiti da "`" (per esempio www`microsoft`com)
[Host_]
nome dell'host in cui tutti i "." sono sostituiti da "_" (per esempio www_microsoft_com)
[Path]
Path dall' URL
[Path`]
Path in cui tutti i "/" sono sostituiti da "`"
[Path_]
Path in cui tutti i "/" sono sostituiti da "_"
[Protocol]
nome del protocollo (ftp,http)
[Ext]
estensione del nome del file nell'URL
[WeekDayS]
Nomi abbreviati dei giorni della settimana
[FullWeekDayS]
Nomi completi dei giorni della settimana
[MonthS]
Nomi abbreviati dei mesi
[FullMonthS]
Nomi completi dei mesi
[Day]
Giorno del mese come numero decimale (1 - 31)
[Hour]
Ora in formato 24-ore (0 - 23)
[Hour12]
Ora in formato 12-ore (1 - 12)
[DayOfYear]
Giorno dell'anno come numero decimale (1 - 366)
[Month]
Mese come numero decimale (1 - 12)
[Minute]
Minuti come numeri decimali (0 - 59)
[AmPm]
Indicatore corrente del locale A.M./P.M. per orologio in formato 12-ore
[Second]
Secondi come numeri decimali (00 - 59)
[Week]
Settimana dell'anno come numero decimale, con la Domenica come primo giorno della settimana (0 - 51)
[Weekday]
Giorno della settimana come numero decimale (0 - 6; Sunday is 0)
[WeekOfYear]
Settimana dell'anno come numero decimale, con il Lunedi come primo giorno della settimana (0 - 51)
[Year]
Anno senza il secolo, come numero decimale (00 - 99)
[Year4]
Anno con il secolo, come numero decimale
[TZ]
Nome o abbreviazione del Fuso Orario; nessun carattere se il fuso orarioè sconosciuto


System tray menu

Menu della barra di sistema

"Apri/Chiudi la finestra di ReGet"– Apre/chiude la finestra di ReGet.
"Nuovo scaricamento..."(Alt+N)– Aggiunge un nuovo scaricamento alla coda corrente. Questo strumento del menu lancia una finestra in cui puoi inserire i dettagli dei nuovi scaricamenti.
"Incolla URL"(Ctrl+V)– Incolla un URL dalla Cartella Appunti alla lista corrente. Tutte le impostazioni per un nuovo download sono ricavate dalle impostazioni predefinite.
"Monitorizza gli appunti"– Se questa funzione è selezionata, ReGet monitorizza la Cartella Appunti. Se ReGet vi trova un URL valido, esso è aggiunto alla coda corrente. Si può anche cambiare questa impostazione nella sezione Monitor Appunti nella finestra Opzioni del programma.
"Priorità di traffico" - Priorità di traffico di ciascun download in coda.
"Proprietà di scaricamento predefinite..." (Alt+Ctrl+O)
"Opzioni..."(Alt+O) -
"Informazioni su..." – Fa apparire una finestra di informazioni sul programma.
"Esci"– Per uscire dal programma.


Command line parameters

Parametri della riga di comando di ReGet

ReGet.exe [opzioni] [url1] [url2] [file1.lst] [file2.lst] [file1.wrg] [file2.wrg]
Per impostazioni predefinite, ReGet apre default.wrg dalla cartella in cui si trova ReGet.exe

-Setup
Installa ReGet sul tuo sistema. Aggiunge degli elementi al menu contestuale di avvio e a quello di MSIE, aggiunge eventi sonori, etc. Utilizza questa opzione se hai spostato ReGet in un'altra cartella
-UnSetup
Cancella ReGet dal registry e dal Menu Avvio. Utilizza questa opzione per disinstallare ReGet manualmente.
-Add
Forza ReGet a passare i parametri alla copia già in esecuzione. Se ReGet non è in esecuzione e non è stata specificata la flag -NoStart, viene lanciata una nuova sessione del programma
-Dial
Forza la copia di ReGet in esecuzione a collegarsi ad Internet
-Hangup
Forza la copia di ReGet in esecuzione a disconnettersi
-cfg:name
Utilizza la configurazione specificata.
-Wizard
Lancia la procedura di installazione
-NoStart
Impedisce l'avvio di ReGet se usato con /Add


Status

Frequently Asked Questions (Domande poste di frequente)
Indice:
  1. Distribuzione e confezionamento:
    1. Posso (o puo' la mia società) distribuire ReGet?
    2. Dove posso trovare la licenza d'uso?
    3. Quali differenze ci sono tra le versioni Pro, Free e Beta?
    4. Quali differenze ci sono tra le versioni Inglese, Giapponese e Russa?
  2. Domande generali:
    1. Sono un webmaster, come posso promuovere ReGet?
    2. Cosa occorre per essere qualificati come beta-tester?
    3. Ho trovato un difetto in ReGet. Cosa dovrei fare?
  3. Domande sulla Connessione:
    1. Come funziona la ripresa del trasferimento in FTP?
    2. Come funziona la ripresa del trasferimento in HTTP?
    3. Perché la dimensione del file non é visibile prelevando i file in FTP via Microsoft Proxy Server?
    4. Effettuo il download da un server FTP che supporta la ripresa dei download interrotti via server proxy, ma "ReGet" riprende sempre il trasferimento dall'inizio. Perchè?
    5. Perché si verifica l'errore "Invalid EOF"?
    6. Che cos'é la modalità "PASV" (modalità passiva)?
    7. Come funziona "Smart Rollback" e a che serve?
    8. Perchè a volte non riesco a trasferire gruppi di file per maschera dai server FTP?
    9. A volte i file che scarico con ReGet non si aprono. Perchè?
  4. Domande sull'Uso di "ReGet":
    1. Come specifico l'username e la password nel nome del file da trasferire (Finestra proprietà di Scaricamento)?
    2. Perchè a volte ReGet smette di trasferire il file al 95-99% e non termina il download?
    3. Quando uso la combinazione ALT-click in Microsoft Internet Explorer 5, non accade nulla (anche se é selezionata l'opzione "Usa il tasto ALT") -- perché?
    4. Perchè a volte ReGet non é in grado di prelevare i file dai Web-server, e il mio browser ci riesce?
    5. Non riesco a prelevare i file da un server FTP, cosa dovrei fare?
    6. Uso Microsoft Proxy server per connettermi ad Internet e ReGet dice: "Only Basic authentification is supported" -- cosa vuol dire?
    7. Posso scaricare interi siti web con ReGet?
    8. Quando provo ad eseguire ReGet non accade nulla - perché?
  5. Suggerimenti Utili:
    1. Come spostare il/i download selezionato/i in cima o in fondo alla lista (coda di scaricamento) in un click?
    2. Come si fa ad accedere rapidamente alle proprietà di Dial Up?
    3. Come si disabilita lo splash screen?
  1. Distribuzione e confezionamento:
    1. Domanda:
      Posso (o puo' la mia società) distribuire ReGet?
      Risposta:
      La risposta breve é "NO". La lunga é che hai bisogno del consenso scritto dell'autore per ridistribuire ReGet gratuitamente o con un contributo aggiuntivo (cio' comprende, ma non si limita alla pubblicazione su server www e server ftp).
      Ti suggeriamo di effettuare un link all'indirizzo
      http://www.reget.com/redir/redir.asp?lang=default&product=reget&link=pro per la versione Internazionale di ReGet Pro
      http://www.reget.com/redir/redir.asp?lang=default&product=reget&link=free per la versione Internazionale di ReGet Free
      http://www.reget.com//redir/redir.asp?lang=jp&product=reget&link=pro per la versione Giapponese di ReGet Pro
      http://www.reget.com/cgi-bin/redir.asp?lang=jp&product=reget&link=free per la versione Giapponese di ReGet Free
      Il motivo per cui ti chiediamo di non effettuare un link al file .exe é che vogliamo essere certi che quando gli utenti prelevano ReGet, scarichino la versione piu' recente, e a meno che tu non ti iscriva alla nostra newsletter, noi non saremo in grado di aggiornarti al momento del rilascio di una nuova versione.
      Se hai scritto e pubblicato da qualche parte una recensione di ReGet, per favore faccelo sapere.
      Torna all'Indice
    2. Domanda:
      Dove posso trovare la licenza d'uso?
      Risposta:
      Puoi trovarla nella cartella di ReGet con il nome di "license.txt".
      Torna all'Indice
    3. Domanda:
      Quali differenze ci sono tra le versioni Pro, Free e Beta?
      Risposta:
      ReGet sarà un prodotto commerciale. ReGet 1.5 sarà confezionato con nuove qualità.
      ReGet Free
      Puoi usarlo gratuitamente per 30 giorni. Successivamente ReGet ti suggerirà di registrarti e, nel caso tu non lo faccia, comincierà a mostrare banner (se la pubblicità non ti disturba, puoi continuare ad usarlo gratuitamente).
      ReGet Pro
      La versione di ReGet con tutte le caratteristiche. Al costo di $20.
      ReGet Beta
      Per favore fai riferimento alla domanda di beta-testing per conoscerne i dettagli.
      Torna all'Indice
    4. Domanda:
      Quali differenze ci sono tra le versioni Inglese, Giapponese e Russa?
      Risposta:
      La versione Internazionale di ReGet 1.5 é in piu' di 16 lingue (puoi trovare l'elenco completo delle lingue sulla nostra pagina dei download). Tuttavia ci sono distribuzioni separate per le versioni nella sola lingua Inglese, Giapponese e Russa.
      Torna all'Indice
  2. Domande generali:
    1. Domanda:
      Sono un webmaster, come posso promuovere ReGet?
      Risposta:
      Preleva subito ReGet! Se vuoi semplificare la vita dei tuoi utenti o semplicemente aggiungere un collegamento a ReGet dalla tua pagina, per favore colloca il distintivo di ReGet (mostrato a sinistra) sulle tue pagine. Il codice HTML da associarvi é mostrato qui sotto. Puoi trovare altri distintivi e banner con i loro codici HTML sulla nostra pagina della grafica dei collaboratori. Se hai scritto e pubblicato da qualche parte una recensione di ReGet, per favore faccelo sapere.
      <A HREF="http://www.reget.com"><IMG
SRC="http://www.reget.com/images/regetnow.gif"
WIDTH="88" HEIGHT="31" BORDER="0" VSPACE="7"
ALT="Download ReGet now!"></A>
      Torna all'Indice
    2. Domanda:
      Cosa occorre per essere qualificati come beta-tester?
      Risposta:
      Abbiamo interrotto il programma di ampio beta-testing. Alcuni utenti/collaudatori riceveranno il login e la password per accedere alla zona protetta del ReGet Beta Server per scaricare le beta di ReGet. Il resoconto dei difetti deve essere inviato a bugreport@reget.com
      Torna all'Indice
    3. Domanda:
      Ho trovato un difetto in ReGet. Cosa dovrei fare?
      Risposta:
      Se hai trovato un difetto, per favore invia una e-mail. Nella tua lettera specifica:
      • L'URL del file che stavi cercando di prelevare.
      • Quale Sistema Operativo stai usando?
      • La copia del log di questo download (puo' essere copiato tramite gli Appunti).
      • La versione di ReGet e il numero di build (si puo' trovare nel menu a tendina ? alla voce Informazioni su...)
      • E la descrizione dell'errore.
      Torna all'Indice
  3. Domande sulla Connessione:
    1. Domanda:
      Come funziona la ripresa del trasferimento in FTP?
      Risposta:
      Gran parte dei server FTP supporta il comando "REST nnn". Quando il client invia questo comando al server, il server invia il file dalla posizione specificata. Il piu' noto server che non riprende i trasferimenti interrotti é Microsoft IIS. Per la precisione, supporta "REST nnn" ma richiede che nnn sia eguale a 0.
      Torna all'Indice
    2. Domanda:
      Come funziona la ripresa del trasferimento in HTTP?
      Risposta:
      Il campo speciale ("Range: bytes nnn-") deve essere fornito nel modulo di richiesta del file. Se il server WWW supporta la ripresa del trasferimento, restituisce il codice 206 e la parte di file specificata. In caso contrario, restituisce l'intero file (come in una normale richiesta).
      Torna all'Indice
    3. Domanda:
      Perché la dimensione del file non é visibile prelevando i file in FTP via Microsoft Proxy Server?
      Risposta:
      MS Proxy non fornisce le dimensioni dei file via FTP. Non é un difetto di "ReGet", é un difetto di MS Proxy. Inoltre, non conoscendo l'effettiva dimensione del file, "ReGet" non puo' determinare le interruzioni della connessione. Percio', se MS Proxy interrompe la connessione, a "ReGet" sembrerà di aver trasferito il file correttamente.
      Torna all'Indice
    4. Domanda:
      Effettuo il download da un server FTP che supporta la ripresa dei download interrotti via server proxy, ma "ReGet" riprende sempre il trasferimento dall'inizio. Perchè?
      Risposta:
      Il server proxy potrebbe non supportare la ripresa del trasferimento (come il Microsoft Proxy Server). Se questo é il caso, puoi provare ad usare la connessione diretta o un client Winsock.
      Torna all'Indice
    5. Domanda:
      Perché si verifica l'errore "Invalid EOF"?
      Risposta:
      C'é un numero di possibili ragioni:
      1) Sul server é settato un tempo limite errato per il trasferimento dei singoli file. Questo problema puo' essere riconosciuto quando i tempi tra l'inizio del trasferimento ed il suo fallimento si equivalgono durante i diversi tentativi.
      2) Errore nel WWW-service software. Per esempio questo difetto é presente in "Apache/1.1.3 rus/PL15R" che processa erroneamente la richiesta di file parziali.
      Puo' esserci anche qualche altra ragione.
      Torna all'Indice
    6. Domanda:
      Che cos'é la modalità "PASV" (modalità passiva)?
      Risposta:
      Solitamente, recuperando i file via FTP, si usano due connessioni: per i comandi e per i dati. La connessione-comandi é stabilita dal client, la connessione-dati é stabilita dal server. In alcuni casi (ad esempio utilizzando un firewall) entrambe le connessioni devono essere stabilite dal client. In casi del genere il server va in modalità passiva quando il comando "PASV" é inviato dal client.
      Torna all'Indice
    7. Domanda:
      Come funziona "Smart Rollback" e a che serve?
      Risposta:
      Smart Rollback puo' essere usato solo effettuando il download tramite server proxy. Quando utilizzi un server proxy, vengono create due connessioni:
      (1) (2)
      Client <-> server proxy <-> server WWW/FTP
      Se si interrompe la prima connessione, non é richiesta ulteriore elaborazione da parte di ReGet.
      Tuttavia, quando si interrompe la seconda connessione, il server proxy spesso invia un messaggio di errore, aggiungendolo alla fine del file scaricato. Sicché, se prosegui nel trasferimento, avrai questo messaggio di errore all'interno del file trasferito. Ci sono due possibili soluzioni:
      1. Quando una delle due connessioni (la prima o la seconda) si interrompono, tagliamo gli ultimi 2Kb del file scaricato (cosi' fa GetRight). Lo svantaggio é che é stata la prima connessione ad essere interrotta (e quindi non c'é materiale estraneo nella porzione di file trasferita), e noi abbiamo perso 2Kb di un file faticosamente scaricato. Inoltre, i messaggi d'errore sono solitamente inferiori a 2Kb, sebbene dipenda dal server e dal tipo di errore.
      2. Ad ogni interruzione, controlliamo gli ultimi 2Kb in cerca della stringa d'errore. L'autore é a conoscenza delle sole due seguenti possibilità: "HTTP/1.x" e "<HTML>" (se ne incontri delle altre, avvisa tramite e-mail l'autore che le aggiungerà al programma). Cosi', se troviamo un messaggio d'errore lo eliminiamo. Se non lo troviamo -- attribuiamo questa interruzione ad una caduta del primo collegamento. Gli svantaggi sono: un messaggio di errore puo essere nel file, ma puo' essere maggiore di 2Kb, i messaggi di errore possono cominciare in modo diverso (da come ci aspettiamo). Caso particolare. Alcuni server proxy (ad esempio Microsoft Proxy Server) non riportano le dimensioni del file quando si effettuano trasferimenti tramite server FTP. Cosi' in caso di errore nella seconda connessione, il solo modo di scoprirlo é usare "Smart rollback". In questo caso (effettuando un download via server proxy, e con dimensioni del file sconosciute) "Smart rollback" é usato SEMPRE.
      Torna all'Indice
    8. Domanda:
      A volte i file che scarico con ReGet non si aprono. Perchè?
      Risposta:
      ReGet 1.4 aveva questo difetto: alcune informazioni occasionali (come gli header dei pacchetti di dati) venivano scritte all'interno del file scaricato. Per favore installa l'ultima versione di ReGet, il difetto é risolto li'.
      Torna all'Indice
    9. Domanda:
      Perchè a volte non riesco a trasferire gruppi di file per maschera dai server FTP?
      Risposta:
      Non puoi usare "*" e "?" negli URL per trasferire i file da un server FTP usando un proxy HTTP.
      Torna all'Indice
  4. Domande sull'Uso di "ReGet":
    1. Domanda:
      Come specifico l'username e la password nel nome del file da trasferire (Finestra proprietà di Scaricamento)?
      Risposta:
      Devi farlo in questo modo: ftp://username:password@ftp.server.com/DirectoryName/file.zip
      Torna all'Indice
    2. Domanda:
      Perchè a volte ReGet smette di trasferire il file al 95-99% e non termina il download?
      Risposta:
      Puo' accadere solo se usi NetSonic. Questo é effettivamente un difetto di NetSonic. Stiamo lavorando a stretto contatto con Web3000 (la società che vende NetSonic), abbiamo provato NetSonic 2.5 BETA per scoprire qualsiasi problema d'incompatibità e tale problema sarà risolto in NetSonic 2.5.
      Torna all'Indice
    3. Domanda:
      Quando uso la combinazione ALT-click in Microsoft Internet Explorer 5, non accade nulla (anche se é selezionata l'opzione "Usa il tasto ALT") -- perché?
      Risposta:
      Molto probabilmente, hai altri programmi integrati in MSIE 5. Questo é il difetto noto di MSIE 5 -- quando piu' di un programma é abilitato a rispondere ai click in MSIE 5, ne viene richiamato solo uno a caso. Abbiamo riferito alla Microsoft di questo difetto e dovrebbe essere risolto nel prossimo Service Pack per IE 5.
      Torna all'Indice
    4. Domanda:
      Perchè a volte ReGet non é in grado di prelevare i file dai Web-server, e il mio browser ci riesce?
      Risposta:
      Molto probabilmente, il server di destinazione sta controllando o il campo "User-agent" o il "Referrer" (o entrambi) che vengono inviati nella richiesta via HTTP. Cerca di disabilitare l'"User-agent" e imposta il "Referrer" con la pagina nella quale hai trovato un collegamento al file. Nella maggior parte dei casi, ReGet puo' ricavare le informazioni necessarie del "Referrer" dal tuo browser, ma talvolta potrebbe non funzionare.
      Torna all'Indice
    5. Domanda:
      Non riesco a prelevare i file da un server FTP, cosa dovrei fare?
      Risposta:
      Se sei connesso ad Internet attraverso un firewall/server proxy, per favore abilita il "PASV mode" nelle impostazioni FTP per i tuoi download.
      Torna all'Indice
    6. Domanda:
      Uso Microsoft Proxy server per connettermi ad Internet e ReGet dice: "Only Basic authentification is supported" -- cosa vuol dire?
      Risposta:
      Significa che ReGet supporta soltanto l'autenticazione di base. Per poter usare con successo ReGet con MS Proxy Server puoi:
      1. Abilitare l'autenticazione di base su MS Proxy Server (se hai i privilegi per amministrarlo)
      2. Installare sul tuo computer locale il Client MS Proxy Winsock che si collegherà con MS Proxy server e tu potrai usare ReGet (solitamente, la sua routine di installazione puo' essere trovata su: \\proxy-server-name\mspclnt\setup.exe)
      Torna all'Indice
    7. Domanda:
      Posso scaricare interi siti web con ReGet?
      Risposta:
      No, non puoi. Forse questa caratteristica sarà implementata in ReGet 2.0. Per adesso ti consigliamo di usare Offline Exporer.
      Offline Explorer é un tool davvero eccellente per scaricare e visualizzare offline i siti web. Nella versione estremamente semplificata, ti lascia inserire un URL e premere il bottone del download per scaricare una pagina e tutti i suoi collegamenti di primo livello. Nella versione piu' complessa, ti lascia il controllo completo sui download da includere o escludere dai singoli server, dalle cartelle, dagli URL e dalle pagine. Sui siti molto grandi, persino scaricare i collegamenti di primo livello puo' risultare un' impresa ardua, per questo motivo creare una lista di parole chiave da includere/escludere ti permette di limitare gli scaricamenti alle zone più rilevanti di un sito. Inoltre, é possibile stabilire dei limiti per i file e i megabyte per tutti i download. Offline Explorer ti consente anche di immettere le password per i siti protetti e di pianificare i trasferimenti ad intervalli regolari. E' dotato di un browser interno (che richiede la presenza nel tuo sistema di Internet Explorer 3.0 o delle versioni superiori), in alternativa puoi visualizzare i siti usando un qualunque browser presente sul tuo computer. I siti scaricati sono conservati come progetti, permettendoti di salvare e tenere traccia di molteplici siti.
      Torna all'Indice
    8. Domanda:
      Quando provo ad eseguire ReGet non accade nulla - perché?
      Risposta:
      E' il noto difetto della Microsoft descritto su http://support.microsoft.com/support/kb/articles/Q170/3/64.ASP?LNG=ENG&SA=AL . Per risolvere questo problema la stringa del valore nominato qui di seguito deve contenere un unico e valido nome di eseguibile per il processo della shell (explorer.exe come predefinito):

      HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon
      Shell=
      Torna all'Indice
  5. Suggerimenti Utili:
    1. Domanda:
      Come spostare il/i download selezionato/i in cima o in fondo alla lista (coda di scaricamento) in un click?
      Risposta:
      Tieni premuto il tasto "CTRL" mentre sposti i file da scaricare per muoverli velocemente in cima o in fondo alla coda (lista degli scaricamenti).
      Torna all'Indice
    2. Domanda:
      Come si fa ad accedere rapidamente alle proprietà di Dial Up?
      Risposta:
      Tenendo premuto il tasto "CTRL" e cliccando sul bottone "Connetti/Disconnetti" sulla barra degli strumenti.
      Torna all'Indice
    3. Domanda:
      Come si disabilita lo splash screen?
      Risposta:
      Aggiungi "/NoSplash" al nome del file nello shortcut (collegamento) a ReGet.
      Torna all'Indice